Important zipForm® Updates

Posted on May 1, 2013 by AAR

Print Friendly

1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading...Loading...
Recently many AAR members have been experiencing troubles with zipForms®, the AAR electronic forms offering. Ron LaMee, senior vice president of business services for AAR wrote a blog post on March 26, giving people an explanation for the problems they might be having. In it he says:

To use zipForm®, you must download and install a Java plug-in from Oracle into your web browser (Firefox, Chrome, Internet Explorer, Safari, etc.). Recently, a series of Java security vulnerabilities in these plug-ins have been revealed. … [T]he recent spate of Java vulnerabilities has resulted in Apple “turning off” Java support in Safari. The net result is that safe Java websites like zipForm® are affected, too.

Following this post, LaMee also sent this message to membership via the AAR Blog about changes happening at zipLogix:

“We’ve been talking about the new, Java-free version of zipForm® lately, but now we have official word about timing for the release.  Here’s a statement from Wendy Waldrep, vice president of sales at zipLogix:

‘We want to officially confirm that zipLogix is working on zipForm® Plus,  a new release that eliminates the need for Java and adds new features.  zipLogix commits  to releasing zipForm® Plus to AAR members in June.  Initially, AAR members will have the ability to switch back and forth from the new application to zipForm® 6 Professional to ease transition to the new platform.’

“As we in Business Services get some experience with zipForm® Plus, we’ll be better able to guide AAR members. Stay tuned for more information as we get closer to the launch” wrote LaMee.

If you are experiencing issues using zipForm®, AAR is here to help. Feel free to call our support team during business hours at Toll Free: (866) 833-7357 or Email AAR Support.

Tags:

Leave a Reply

You must be logged in to post a comment.